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Tumor Removal
Introduction
One method for removing cancerous tumors from healthy tissue is to heat the malignant tissue to a
critical temperature that kills the cancer cells. This example accomplishes the localized heating by
inserting a four-armed electric probe through which an electric current runs. Equations for the electric
field for this case appear in the Conductive Media DC application mode, and this example couples them
into the bioheat equation, which models the temperature field in the tissue. The heat source resulting
from the electric field is also known as resistive heating or Joule heating. The original model comes
from S. Tungjitkusolmun and others (Ref. 1), but we have made some simplifications. For instance,
while the original uses RF heating (with AC currents), the COMSOL Multiphysics model approximates the
energy with DC currents.
This medical procedure removes the tumorous tissue by heating it above 45 °C to 50 °C. Doing so
requires a local heat source, which physicians create by inserting a small electric probe. The probe is
made of a trocar (the main rod) and four electrode arms as shown in Figure 4-1. The trocar is
electrically insulated except near the electrode arms.
An electric current through the probe creates an electric field in the tissue. The field is strongest in the
immediate vicinity of the probe and generates resistive heating, which dominates around the probe’s
electrode arms because of the strong electric field.

Figure 4-1: Cylindrical modeling domain with the four-armed electric probe in the middle, which is located next to a large blood
vessel.

Model Definition
This model uses the Bioheat Equation and the Conductive Media DC application modes to implement a
transient analysis.
The standard temperature unit in COMSOL Multiphysics is kelvin (K). This model uses the Celsius
temperature scale, which is more convenient for models involving the Bioheat Equation.
The model approximates the body tissue with a large cylinder and assumes that its boundary
temperature remains at 37 °C during the entire procedure. The tumor is located near the center of the
cylinder and has the same thermal properties as the surrounding tissue. The model locates the probe
along the cylinder’s center line such that its electrodes span the region where the tumor is located. The
geometry also includes a large blood vessel.
The bioheat equation governs heat transfer in the tissue

3

where δts is a time-scaling coefficient; ρ is the tissue density (kg/m ); C is the tissue’s specific heat (J/
(kg·K)); and k is its thermal conductivity (W/(m·K)). On the right side of the equality, ρb gives the

3

blood’s density (kg/m ); Cb is the blood’s specific heat (J/(kg·K)); ωb is its perfusion rate (1/s); Tb is
the arterial blood temperature (°C); while Qmet and Qext are the heat sources from metabolism and
3

spatial heating, respectively (W/m ).
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In this model, the bioheat equation also models heat transfer in various parts of the probe with the
appropriate values for the specific heat, C (J/(kg·K)), and thermal conductivity, k (W/(m·K)). For these
parts, all terms on the right-hand side are zero.
The model next sets the boundary conditions at the outer boundaries of the cylinder and at the walls of
the blood vessel to a temperature of 37 °C. Assume heat flux continuity on all other boundaries.
The initial temperature equals

37 °C in all domains.

The governing equation for the Conductive Media DC application mode is

V is the potential (V), σ the electric conductivity (S/m), Je an externally generated current
2
3
density (A/m ), Qj the current source (A/m ).
where

e

In this model both J and

Qj are zero. The governing equation therefore simplifies into:

.

The boundary conditions at the cylinder’s outer boundaries is ground (0 V potential). At the electrode
boundaries the potential equals 23 V. Assume continuity for all other boundaries.
The boundary conditions for the Conductive Media DC application mode are:

The boundary conditions for the bioheat equation are:

The model solves the above equations with the given boundary conditions to obtain the temperature
field as a function time.

Results and Discussion
The model shows how the temperature increases with time in the tissue around the electrode.
The slice plot in Figure 4-2 illustrates the temperature field 60 seconds after starting the procedure.

Figure 4-2: Temperature field at time = 60 seconds.
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Figure 4-3 shows the temperature at the tip of one of the electrode arms. The temperature rises quickly
until it reaches a steady-state temperature of about 90 °C.

Figure 4-3: Temperature versus time at the tip of one of the electrode arms.

It is also interesting to visualize the region where cancer cells die, that is, where the temperature has
reached at least 50 °C. You can visualize this area with an isosurface for that temperature; Figure 4-4
shows one after 8 minutes.

Figure 4-4: Visualization of the region that has reached 50 °C after 8 minutes.
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Model Library Path:
Heat_Transfer_Module/Medical_Technology/tumor_ablation

Modeling Using the Graphical User Interface
MODEL NAVIGATOR
1

Open the Model Navigator. On the New page, select 3D in the Space dimension list.
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2

Go to the Heat Transfer Module menu and select Bioheat Equation>Transient analysis.

3

Click the Multiphysics button and add the application mode to the model by clicking the Add
button.

4

Similarly add the Conductive Media DC application mode, from the
COMSOL Multiphysics>Electromagnetics menu.

5

Click OK.

OPTIONS AND SETTINGS
1

Define the following constants in Constants under the Options menu:

NAME

EXPRESSION

rho_e

6450[kg/m^3]

rho_t

21500[kg/m^3]

rho_l

1060[kg/m^3]

rho_b

1000[kg/m^3]

rho_c

70[kg/m^3]

c_e

840[J/(kg*K)]

c_t

132[J/(kg*K)]

c_l

3600[J/(kg*K)]

c_b

4180[J/(kg*K)]

c_c

1045[J/(kg*K)]

k_e

18[W/(m*K)]

k_t

71[W/(m*K)]

k_l

0.512[W/(m*K)]

k_b

0.543[W/(m*K)]

k_c

0.026[W/(m*K)]

sigma_e

1e8[S/m]

sigma_t

4e6[S/m]

sigma_l

0.333[S/m]

sigma_b

0.667[S/m]

sigma_c

1e-5[S/m]

T_b

37[degC]

Arterial blood temperature

omega_b

6.4e-3[1/s]

Blood perfusion rate

T0

37[degC]

Initial temperature

V0

22[V]

2

DESCRIPTION

Density

Density, blood

Heat capacity, tumor

Heat capacity, blood

Thermal conductivity, tumor

Thermal conductivity, blood

Electric conductivity, tumor

Electric conductivity, blood

Click OK.

GEOMETRY MODELING
1

Go to the Draw menu and select Work-Plane Settings.

2

Create an x-y plane at the z coordinate 0.06.
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3

Click OK.

4

Press the Shift key and click the Ellipse/Circle (Centered) button.

5

In the dialog box that appears, enter the following circle properties:

OBJECT
DIMENSIONS

EXPRESSION

Radius

9.144e-4

Base

Center

x

0

y

0

6

Click OK.

7

Click the Zoom Extents button on the Main toolbar.

8

Repeat Steps 4–6 to create five additional circles, for smaller ones and a large one. The properties of
each circle appear in the following five tables:

OBJECT
DIMENSIONS

EXPRESSION

Radius

2.667e-4

Base

Center

x

-5e-4

y

0

OBJECT
DIMENSIONS

EXPRESSION

Radius

2.667e-4

Base

Center

x

5e-4

y

0

OBJECT
DIMENSIONS

EXPRESSION

Radius

2.667e-4

Base

Center

x

0

y

-5e-4

OBJECT
DIMENSIONS

EXPRESSION

Radius

2.667e-4

Base

Center

x

0

y

5e-4

OBJECT
DIMENSIONS

EXPRESSION
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Radius

5e-3

Base

Center

x

2.6e-2

y

0

9

Click the Zoom Extents button on the Main toolbar.

This completes the geometry needed in the 2D work plane, and the result appears in Figure 4-5.

Figure 4-5: 2D working plane geometry.

The following steps describe how to create the 3D geometry by extruding and revolving the 2D
geometry:
1

To create the conducting part of the trocar, go to the Draw menu and select Extrude.

2

In the dialog box that appears, select C1 in the Objects to extrude list and type 10e-3 in the
Distance edit field.

3

Click OK.

4

To create the insulated part of the trocar, return to the Geom2 work plane, then go to the Draw
menu and select Extrude.

5

Select C1 in the Objects to extrude list and type 50e-3 in the Distance edit field.

6

Click OK.

7

Select the EXT2 geometry object.

8

Click the Move button on the Draw toolbar.

9

Enter the following displacement values; when finished, click OK.

PROPERTY

VALUE

x

0

y

0

z

10e-3

To create the electrode arms, proceed as follows:
10 Return to the Geom2 work plane.
11 From the Draw menu select Revolve.
12 From the Objects to revolve list select C2.
13 Enter the following values in the dialog box; when finished, click OK.
PROPERTY

VALUE
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α1

0

α2

180

x (point on axis)

-8e-3

y (point on axis)

0

x (second point)

-8e-3

y (second point)

1

14 Revolve the circles C3, C4, and C5 in the same manner using the following values.
Revolve parameters for the circle C3:
PROPERTY

VALUE

α1

0

α2

-180

x (point on axis)

8e-3

y (point on axis)

0

x (second point)

8e-3

y (second point)

1

Revolve parameters for the circle C4:
PROPERTY

VALUE

α1

-180

α2

0

x (point on axis)

0

y (point on axis)

-8e-3

x (second point)

1

y (second point)

-8e-3

Revolve parameters for the circle C5:
PROPERTY

VALUE

α1

180

α2

0

x (point on axis)

0

y (point on axis)

8e-3

x (second point)

1

y (second point)

8e-3

15 To create the blood vessel, return to the Geom2 work plane and select C6.
16 Go to the Draw menu and select Extrude.
17 In the Distance field enter 120e-3.
18 Click OK.
19 Select the EXT3 geometry object, go to the Draw menu and select Move under Modify.
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20 Enter the following displacement values; when finished, click OK.
PROPERTY

VALUE

x

0

y

0

z

-60e-3

21 To create the large cylinder, press the Shift key and click the Cylinder button.
22 Enter the following cylinder properties; when finished, click OK.
PROPERTY

VALUE

Radius

0.05

Height

0.12

23 Click the Zoom Extents button on the Main toolbar.
This concludes the drawing stage. To get a better view of the geometry you have created, do as
follows:
1

To hide the coordinate axes, double-click the AXIS button on the status bar at the bottom of the
user interface.

2

From the Options menu select Visualization/Selection Settings.

3

Clear the Geometry labels check box, then click OK.

4

Choose Options>Suppress>Suppress Boundaries.

5

Select Boundaries 34, 47, 58, 59, 62, and 63, then click OK.

6

Click the Perspective Projection button on the Camera toolbar.

7

Finally, after rotating the geometry in the drawing area upside down you should have a view similar
to that in Figure 4-1 on page 246.

PHYSICS SETTINGS

Subdomain Settings—Bioheat Equation
1

In the Multiphysics menu select 1 Bioheat Equation (htbh).

2

In the Physics menu select Subdomain Settings.

3

Select Subdomain 8 and clear the Active in this domain check box.

4

Enter the properties for the remaining subdomains as follows:

SETTINGS

SUBDOMAIN
1

SUBDOMAINS
2, 5-7

SUBDOMAIN
3

SUBDOMAIN
4

k

k_l

k_e

k_t

k_c

ρ

rho_l

rho_e

rho_t

rho_c

C

c_l

c_e

c_t

c_c

ρb

rho_b

Cb

c_b

ωb

omega_b

Tb

T_b
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5

On the Init page, select all active subdomains and in the T(t0) edit field type T0.

6

To reduce the size of the computation problem, select a lower element order by choosing the
Element tab and then select Lagrange - Linear from the list of Predefined elements for all
active subdomains.

7

Click OK.

Boundary Conditions—Bioheat Equation
8

Go to the Physics menu and select Boundary Settings.

9

Enter boundary coefficients as follows:

SETTINGS

BOUNDARIES
1-4, 34 47, 58,
59, 62, 63

BOUNDARY 20

Boundary
condition

Temperature

Thermal
insulation

T0

T_b

10 Click OK.

Subdomain Settings—Conductive Media DC
1

Go to the Multiphysics menu and select 2 Conductive Media DC (dc).

2

Go to the Physics menu and select Subdomain Settings.

3

Enter the subdomain properties as in the following table:

SETTINGS

SUBDOMAIN
1

SUBDOMAINS
2, 5–7

SUBDOMAIN
3

SUBDOMAIN
4

SUBDOMAIN
8

σ

sigma_l

sigma_e

sigma_t

sigma_c

sigma_b

(isotropic)

4

Reduce the element order also for this application mode: On the Element page, select Lagrange Linear from the list of Predefined elements for all subdomains.

5

Click OK.

Boundary Conditions—Conductive Media DC
1

From the Physics menu open the Boundary Settings dialog box.

2

Select the Interior boundaries check box and enter boundary coefficients as in the table below.
You only need to set the boundary condition on the boundaries that use Electric potential. The
remaining boundaries already have the correct conditions set by default, that is, Ground for outer
boundaries and Continuity for interior boundaries.

SETTINGS

BOUNDARIES
5-16, 21-33, 3539, 41-43, 45, 46,
48-57

BOUNDARIES
1-4, 20, 34,
47, 60, 61

BOUNDARIES
17-19, 40, 44,
58, 59, 62, 63

Boundary
condition

Electric potential

Ground

Continuity

V

V0
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Click OK.

MESH GENERATION
1

From the Mesh menu select Free Mesh Parameters.

2

From the Predefined mesh sizes list select Fine.

3

Click the Custom mesh size button, then modify the Element growth rate from the default value
to 1.7.

4

Click Remesh, then click OK.

COMPUTING THE SOLUTION
1

Click the Solver Parameters button on the Main toolbar.

2

From the Solver list select Time dependent.

3

On the General page, type 0 600 in the Times field.

4

From the Linear system solver list select Direct (UMFPACK).

5

From the Matrix symmetry list select Nonsymmetric.

6

Go to the Time Stepping tab and select Time steps from solver in the Times to store in output
list.

7

Select the Manual tuning of step size check box and type 0.01 in the Initial time step edit field
and 50 in the Maximum time step edit field.

8

Click OK.

9

Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION
The default plot is a slice plot of the temperature at time =
Figure 4-2, follow these steps:

600 seconds. In order to generate

1

Click the Plot Parameters button on the Main toolbar.

2

On the General page select Interpolated from the Solution at time list.

3

In the Time edit field type 60.

4

Click the Slice tab and locate the Slice data area. From the Predefined quantities list select

o

Temperature and from the Unit list select C.
5

In the Slice positioning area set the number of x levels, y levels, and z levels to 1, 1, and 0,
respectively.

6

Click Apply.

The following steps describe how to generate the plot in Figure 4-4, which shows the isosurface for the
temperature 50 °C, after 8 minutes:
1

Return to the General page, then clear the Slice check box and select the Isosurface check box.

2

In the Time edit field type 480.

3

Click the Isosurface tab. On the Isosurface Data page, select Temperature from the list of

o

Predefined quantities and select C from the Unit list.
4

In the Isosurface levels area, type 50 in the edit field for Vector with isolevels.

5

Click OK.
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To finish the plot, click the Scene Light button on the Plot toolbar, then click the Increase
Transparency button 5–6 times.
Clicking the Decrease Transparency button repeatedly returns the transparency settings to the
original state.

To create Figure 4-3, which shows temperature versus time, do the following steps:
1

From the Postprocessing menu select Domain Plot Parameters.

2

On the General page, click the Point plot option button under Plot type.

3

On the Point page, select Point 43. From the Unit list select oC, then click OK.

The postprocessing image that is shown when you open the tumor ablation model from the model
library is created with the following steps:
1

Click the Plot Parameters button on the Main toolbar.

2

On the General page, clear the Isosurface check box and select the Streamline and Slice check
boxes.

3

On the Streamline page, select Heat flux from the list of Predefined quantities.

4

On the Start Points page, select Specify start point coordinates, then specify the following
settings in the x, y, and z edit fields:

COORD.

VALUE

x

linspace(0.02,0.02,30)

y

linspace(-0.04,0.04,10) linspace(-0.04,0.04,10) linspace
(-0.04,0.04,10)

z

linspace(0.05,0.05,10) linspace(0.08,0.08,10) linspace
(0.02,0.02,10)

5

On the Line Color page, select the Use expression option button, then click the Color Expression
button. In the dialog box that appears, clear the Color scale check box (leave the default settings in
the Streamline color data area). Click OK.

6

Set the Line type to Tube, then click the Tube Radius button. In the dialog box that appears,
clear the Auto check box for the Radius scale factor, then type 0.1 in the edit field. Click OK.

7

Click the Slice tab. In the Slice positioning area set the number of x levels, y levels, and
z levels to 1, 0, and 0, respectively.

8

Click OK.
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